[arch-general] Corruption with new intel driver

Rafa Griman rafagriman at gmail.com
Tue May 5 09:56:31 EDT 2009

Hi :)

On Thursday 16 April 2009 13:43:58 李业 wrote:
> The new X server will automatically load dri2 if you don't explicitly
> define dri in load module section, and dri2 needs uxa. So if you try
> to use dri+uxa or dri2+exa, X server would hang up just like you
> described. I met the same problem last night, and this is my
> conclusion from Xorg.log.0.

Haven't been able to try this before but I've tried it now and still get the 
same issue (yup, latest patches installed).

I've tried:
	- NOT using an xorg.conf file
	- using a minimal xorg.conf file WITHOUT the dri option
	- using a minimal xorg.conf file defining dri2
	- any other combination my brain could work out

But it still hangs.

No matter what I do, I see the following in the Xorg.log (_without_ the Load 
"dri" option, minimal xorg.conf with AccelMethod UXA only):

----- *** ----- *** ----- *** ----- *** ----- *** -----
# grep -i dri /var/log/Xorg.0.log

(II) "dri" will be loaded by default.
(II) "dri2" will be loaded. This was enabled by default and also specified in 
the config file.
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
(II) Loading extension DRI2
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
(II) Loading extension XFree86-DRI
(II) Loading /usr/lib/xorg/modules/drivers//intel_drv.so
(II) intel(0): [DRI2] Setup complete
(II) UXA(0): Driver registered support for the following operations:
(II) intel(0): 0x007bf000-0x0fff4fff: DRI memory manager (254168 kB)
(II) intel(0): direct rendering: DRI2 Enabled
(II) AIGLX: Loaded and initialized /usr/lib/xorg/modules/dri/i915_dri.so
(II) GLX: Initialized DRI2 GL provider for screen 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: node name is /dev/dri/card0
(II) intel(0): [DRI2] Setup complete
----- *** ----- *** ----- *** ----- *** ----- *** -----

As you can see, dri gets loaded as well. I'm not sure if that's OK. And I am 
using UXA, but it still hangs up.

My UXA testing was done using the following options (tried them all at once, 
one by one, skipping one or the other, ... any combination you can imagine):

----- *** ----- *** ----- *** ----- *** ----- *** -----
        #Option     "AccelMethod"     "UXA"
        #Option     "Framebuffer"     "false"
        #Option     "Tiling"          "false"
        #Option     "EnablePageFlip"  "true"
----- *** ----- *** ----- *** ----- *** ----- *** -----

I don't use my laptop for gaming or 3D or scientific viz so I'm fine using the 
EXA acceleration. I'm just giving some feedback in case the maintainer 
needs/wants it.


"We cannot treat computers as Humans. Computers need love."

rgriman at skype.com
rgriman at jabberes.org

More information about the arch-general mailing list