[arch-general] Strange wpa_supplicant error

Edgar Kalkowski eMail at edgar-kalkowski.de
Sun May 10 08:42:32 EDT 2009

Hello Arch!

I’m connecting to my WPA2 encrypted wireless network via wpa_supplicant. The configuration in /etc/wpa_supplicant.conf looks like this:

        ssid="Hochst van Vaarenhochst"

I start wpa_supplicant in rc.local (and also start dhclient afterwards) and usually everything works just fine. I’m connected to my WLAN after startup and can surf the internet.

However sometimes it occurs that wpa_supplicant does not reach the “Completed” stage but rather remains in the “4-Way-Handshake” stage forever. When observing wpa_supplicant e.g. via wpa_cli it writes “Associated to <bssid>” with the correct bssid of my access point on and on and on ...

A log file that was generated by

$ wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf -dd > bug.txt

can be found at http://xpeter.de/bug.txt. The described behaviour occurs randomly on startup or wakeup from suspend and usually even a reboot does not fix this problem (just time or many reboots does). I’ve also tried to restart my WLAN router but that did also not solve the problem.

Can someone tell me what I’m doing wrong or what could cause this error?

Or, if not, does someone know where I could post this error to people who know?

Best regards!


PS: wpa_supplicant is version 0.6.9 and I’m on stock 2.6.29-ARCH kernel with ndiswrapper driver for my “Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter” (as madwifi did not work half a year back when I tried). Anything else I could provide that might help?
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <http://www.archlinux.org/pipermail/arch-general/attachments/20090510/eafddabd/attachment.pgp>

More information about the arch-general mailing list