[arch-general] Segmentation fault in X after last upgrade

Tobias Kieslich tobias at justdreams.de
Wed Nov 11 13:50:30 EST 2009

On Mon, 02 Nov 2009, Magnus Therning wrote:
> Well, all I'm really interested in is finding out whether it's
> xorg-server or xf86-video-nv which is broken.  Then raise a bug, and
> get it fixed :-)

I just add here that I had a similar issue, which I *thought* I was able
to track down to a broken gtk2 package. And since I use xfce4 stuff
segfaulted when I tried to bring up X. I the used openbox (which uses
pango but not gt2) and that was fine until I tried packages that depend
on gtk2 -> segfaults again. I rebuild gtk2, pacman -U <gtk-package> and
it worked.
However, a day later I pacman -U <downloaded, supposedly bad package
from package cache> and all still worked. I opened a bug, but sinmce I
can't reproduce it I dunno really what happened. Istill think though
that something in the xorg,gtk2 and companions update was borked, I have
no idea what though, but I think it's unrelated to graphic drivers.


More information about the arch-general mailing list