[arch-general] wchan info in ps

Dimitrios Apostolou jimis at gmx.net
Mon Nov 16 15:35:35 EST 2009

On Sat, 14 Nov 2009, Xavier wrote:
> On Sat, Nov 14, 2009 at 7:12 PM, Dimitrios Apostolou <jimis at gmx.net> wrote:
>> Hello list,
>> is anyone actually getting WCHAN information from either ps or top? To try
>> it just use "ps opid,wchan,cmd". I only get dashes, any idea why?
> man ps
> wchan      WCHAN    name of the kernel function in which the process
> is sleeping, a "-" if the process is running, or a "*" if the process
> is multi-threaded and ps is not displaying threads.
> That said, I only get a dash for the ps itself, and sometimes also for
> the shell.
> 4040 n_tty_ -zsh
> 4620 rt_sig zsh
> 4626 poll_s irssi
> 12880 pause  screen -r
> 12942 rt_sig /bin/zsh
> 14936 rt_sig /bin/zsh
> 14939 poll_s cmus
> 23759 poll_s vim lib/libalpm/dload.c
> 23770 rt_sig /bin/zsh
> 23842 -      ps opid,wchan,cmd

I still can't figure this one out. The output you get is the correct one 
(I get that on Redhat systems) however how did you manage to get it on 
arch??? I tried on two more PCs with archlinux, but I still get dashes! 
So I see the same bogus behavior on 3 different systems (all 32-bit), I 
guess it's not my fault.



More information about the arch-general mailing list