[arch-general] successful pacman -Syu w/new kernal26: Now have microscopic console font :-(

Joe(theWordy)Philbrook jtwdyp at ttlc.net
Sat Apr 10 12:00:53 EDT 2010


I just did a pacman -Syu.  It updated lots of stuff. 
The only issues listed in my pacman.log were:
While: updating keystore /etc/ssl/certs/java/cacerts...
ignored import, signature not available: /etc/ssl/certs/COMODO_Certification_Authority.pem
keytool error: java.security.NoSuchAlgorithmException: SHA384withECDSA Signature not available

And a warning about my manually managed separate primary boot partition
not being mounted... Which will never be mounted during *_any_* Linux 
distro's upgrade process... 

I compared /boot and /mnt/boot grub entries, verified that the vmlinuz and
kernel.img filenames hadn't changed, Then copied the vmlinuz, and
both kernal.img files from /boot, to /mnt/boot And rebooted...

As far as I can see (so far) the only real issue I have with my upgraded
Arch system is that the size of my console fonts has drastically been

Once the gui started, all the X font sizes were just fine.  But my eyes
hurt just trying to read the console well enough to login to run startx...

The next thing I did was to edit MY grub's kernel line to include:
vga=normal, and rebooted. But partway through the boot messages the
screen still clears and the font size becomes painfully small.

Next, Even though I've never had to bother with framebuffer before (I
prefer the normal sized console font, and I don't like pretty pictures on
my screen until AFTER I run startx...) I read the "FRAMEBUFFER RESOLUTION
SETTINGS" comments in the /boot/grub/menu.lst file. And that led me to
the framebuffer section of the grub wiki file. Which in turn led to my
installing hwinfo from aur on this amd_64 laptop.

02: None 00.0: 11001 VESA Framebuffer 
  [Created at bios.459] 
  Unique ID: rdCR.mrzO17IxmKC 
  Hardware Class: framebuffer 
  Model: "ATI MS48" 
  Vendor: "ATI Technologies Inc." 
  Device: "MS48" 
  SubVendor: "ATI Radeon® Xpress 1150" 
  Revision: "01.00" 
  Memory Size: 16 MB 
  Memory Range: 0xc8000000-0xc8ffffff (rw) 
  Mode 0x0312: 640x480 (+1920), 24 bits
the comments in the menu.lst file say on the 16MB line "0x312=786"
So I tried vga=786 And rebooted...
Just before the boot messages list ":: Bringing up loopback interface"
the screen still clears {expletive-deleted!} And then the fontsize still makes me
squint. {many expletives-deleted!}

Problem #1 

How can I stop the reduction in the console font size??? 

Evidently the framebuffer setting isn't doing it...

Problem #2

How can I stop the boot process from clearing the screen on tty1???

I really dislike ANY of the boot messages to disappear. I "LIKE"
being able to use gpm to copy/paste them into a console editor...
I didn't like it when it cleared the last few lines just prior to giving
me a login prompt. But at least that could be compensated for by the
kludge of including a multi-line echo statement in /etc/rc.local.
But now that it lops the majority of the boot messages off the top
it's beyond my ability to kludgon it into submission. ;-(

Suggestions anyone?

|  ~^~   ~^~
|  <?>   <?>       Joe (theWordy) Philbrook
|      ^                J(tWdy)P
|    \___/         <<jtwdyp at ttlc.net>>

I'm NOT clueless... But I just don't know.  	

More information about the arch-general mailing list