[arch-general] Network troubles

Philipp hollunder at lavabit.com
Mon Oct 18 15:24:05 EDT 2010

I recently dealt a lot with my laptops network configuration because I
needed wlan for uni. Sadly the free driver for my chip still doesn't
work, however, with the proprietary broadcom it works. While
troubleshooting the wlan issues I ditched wicd (because it's buggy,
even the dev doesn't use it anymore) and went a level lower.

As stated before, wlan works at uni and at home as it should, using just
wpa_supplicant and dhcpcd, however, I also need wired network at home,
and whatever I try it just doesn't work.

I suspect the problem might have existed with wicd already, as it worked
with static IP, but not using dhcp.
Now I try to use /etc/rc.d/network but without success so far.

Here's some typical output:
$ sudo /etc/rc.d/network restart
:: Stopping Network                                                         [DONE]
:: Starting Network                                                         [BUSY]
up: error fetching interface information: Device not found
wlan0     Link encap:Ethernet  HWaddr 00:22:69:73:3C:68  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::222:69ff:fe73:3c68/64 Scope:Link
          RX packets:12682 errors:0 dropped:0 overruns:0 frame:7068
          TX packets:7825 errors:9 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:16755594 (15.9 Mb)  TX bytes:652987 (637.6 Kb)

The network fails to start most of the time, but manual ifconfig eth0 up
and manual starting of dhcpcd works just fine.
The probably relevant config parts are:

INTERFACES=(lo eth0)

DAEMONS=(syslog-ng sensors network @alsa @ntpd @crond @cups @laptop-mode)


# A sample configuration for dhcpcd.
# See dhcpcd.conf(5) for details.

# Inform the DHCP server of our hostname for DDNS.
# To share the DHCP lease across OSX and Windows a ClientID is needed.
# Enabling this may get a different lease than the kernel DHCP client.
# Some upstream DHCP servers may also require a ClientID, such as FRITZ!Box.

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
# Most distributions have NTP support.
option ntp_servers
# Respect the network MTU.
option interface_mtu
# A ServerID is required by RFC2131.
require dhcp_server_identifier

# A hook script is provided to lookup the hostname if not set by the DHCP
# server, but it should not be run by default.
nohook lookup-hostname

I'm not sure what else is relevant. I especially have no idea where the
error output comes from and what's wrong. I also assume dhcpcd is
supposed to be running automatically by the network daemon/script, but
that doesn't seem to happen in my case.


More information about the arch-general mailing list