[arch-general] New nvidia driver - video mode not recognized - remove vga= from kernel line?

David C. Rankin drankinatty at suddenlinkmail.com
Thu Oct 28 01:06:53 EDT 2010

On 10/27/2010 11:15 PM, Robert Howard wrote:
> I believe this is occurring before the nvidia driver gets involved. Have you
> tried downgrading nvidia?

Not yet, but I don't know what else could have caused this. I have used scan
(same thing as just pressing enter) and I get about 50 valid modes to enter.
Everything thing from vga to 1920x1200. I have tried entering the listed modes
(e.g. 31A) and it just gives me the same 'invalid mode' prompt.

I've been through the KMS page that just refers you to
https://wiki.archlinux.org/index.php/NVIDIA for nvidia cards. This card is an
8800GT so I have always used:

# pacman -S nvidia nvidia-utils

to install the driver and I've never had any issues. I haven't specifically set
anything for KMS with nvidia boxes. So I'm at a loss at what changed.

The problem I have is that I don't know what process does the mode check and
then throws the invalid mode error? Is it a kernel process, nvidia driver
process. (I suspect a driver process since it is setting the framebuffer, but I
could be totally wrong)

I'm open to all suggestions. I'll give the downgrade a try tomorrow or Friday
when I get a chance. Thanks for the suggestions.

David C. Rankin, J.D.,P.E.
Rankin Law Firm, PLLC
510 Ochiltree Street
Nacogdoches, Texas 75961
Telephone: (936) 715-9333
Facsimile: (936) 715-9339

More information about the arch-general mailing list