[arch-general] build help needed, Trinity kdebase - 2 issues on Arch

David C. Rankin drankinatty at suddenlinkmail.com
Fri Feb 4 22:19:51 EST 2011

On 02/04/2011 07:21 PM, Ray Rashif wrote:
> On 5 February 2011 08:34, David C. Rankin
> <drankinatty at suddenlinkmail.com>  wrote:
>> (1) use vbox?
>> or
>> (2) use a chroot?
> (2)
> pacman -S devtools
> extra-i686-build (in PKGBUILD dir)
> That makes use of mkarchroot and makechrootpkg [1], which makes use of chroot.
> They are right, some KDE3 applications where no amount of
> configuration helps only build properly in a clean chroot, without the
> KDE4 stuff around.
> https://wiki.archlinux.org/index.php/DeveloperWiki:Building_in_a_Clean_Chroot

Ray, Allan, All,

	I got mkarchroot setup in /dat_e/david/bld/root and I created a custom repo 
with all necessary dependency packages for the Trinity kdebase build in 
/dat_e/david/bld/root/chrepo and added the repo to ..bld/root/etc/pacman.conf 
and updated the mkarchroot. (I ran a test by building rpncalc from AUR and it 
worked perfectly)

	I have my copy of kdebase in /dat_e/david/bld/tmp/kdebase. Running sudo 
makechrootpkg -r /dat_e/david/bld installs all the dependencies and all the 
previously built trinity packages just fine. But then cmake fails before it even 
starts for the kdebase build with the following:

21:02 archangel:/dat_e/david/bld/tmp/kdebase> sudo makechrootpkg -r /dat_e/david/bld
==> Making package: trinity 9999-1.0 (Sat Feb  5 03:02:26 UTC 2011)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
==> Extracting Sources...
==> Starting build()...
CMake Error: The source directory "/build" does not appear to contain 
Specify --help for usage, or press the help button on the CMake GUI.
Build failed, check /dat_e/david/bld/copy/build

	I see that /dat_e/david/bld/copy holds a copy of the chroot and 
/dat_e/david/bld/copy/build holds the PKGBUILD pkg, and src dirs. But cmake is 
obviously not happy with the setup. CMakeList.txt is in my source kdebase dir, 
but not the root or copy directories created by mkarchrootpkg. Is there 
something I need to modify or change in PKGBUILD or the mkarchroot setup to have 
it work with cmake??

	Any help appreciated.

David C. Rankin, J.D.,P.E.

More information about the arch-general mailing list