[arch-general] Problems with nvidia card

Ondřej Kučera ondrej.kucera at centrum.cz
Sat Feb 26 06:02:24 EST 2011


I have a fresh Arch Linux installation on a Lenovo T410 laptop which has 
the following graphics card:
01:00.0 VGA compatible controller: nVidia Corporation GT218 [NVS 3100M] 
(rev a2)

At first I tried the nouveau driver, following the description on 
https://wiki.archlinux.org/index.php/Nouveau. Using this driver, the X 
server "freezes" every couple of hours (sometimes once a day, sometimes 
five times a day): mouse pointer moves around the screen, even music 
keeps playing but mouse clicking has no effect and neither has keyboard 
typing. I tried suspending desktop effects in KDE, then I even 
uninstalled nouveau-dri but it keeps happening anyway. This is what I 
found in /var/log/Xorg.log in some cases:

[ 49693.881] [mi] EQ overflowing. The server is probably stuck in an 
infinite loop.
[ 49693.940] 


[ 49694.120] 0: /usr/bin/X (xorg_backtrace+0x28) [0x49f718] 

[ 49694.120] 1: /usr/bin/X (mieqEnqueue+0x1f4) [0x49eb14] 

[ 49694.120] 2: /usr/bin/X (xf86PostKeyEventP+0x67) [0x47c0d7] 

[ 49694.120] 3: /usr/bin/X (xf86PostKeyboardEvent+0x19) [0x47c249] 

[ 49694.121] 4: /usr/lib/xorg/modules/input/evdev_drv.so 
(0x7f9b0f6de000+0x4700) [0x7f9b0f6e2700]
[ 49694.121] 5: /usr/bin/X (0x400000+0x698e7) [0x4698e7] 

[ 49694.121] 6: /usr/bin/X (0x400000+0x118a93) [0x518a93] 

[ 49694.121] 7: /lib/libpthread.so.0 (0x7f9b13dfa000+0xf150) 
[ 49694.121] 8: /lib/libc.so.6 (ioctl+0x7) [0x7f9b12e28aa7] 

[ 49694.122] 9: /usr/lib/libdrm.so.2 (drmIoctl+0x28) [0x7f9b115e7268] 

[ 49694.122] 10: /usr/lib/libdrm.so.2 (drmCommandWrite+0x1b) 
[ 49694.122] 11: /usr/lib/libdrm_nouveau.so.1 (0x7f9b10fa7000+0x2ead) 
[ 49694.122] 12: /usr/lib/libdrm_nouveau.so.1 
(nouveau_bo_map_range+0xfe) [0x7f9b10faa4ce]
[ 49694.122] 13: /usr/lib/libdrm_nouveau.so.1 (0x7f9b10fa7000+0x1f3d) 
[ 49694.122] 14: /usr/lib/libdrm_nouveau.so.1 
(nouveau_pushbuf_flush+0x1af) [0x7f9b10fa953f]
[ 49694.122] 15: /usr/lib/xorg/modules/libexa.so (0x7f9b10b6c000+0x9165) 
[ 49694.122] 16: /usr/lib/xorg/modules/libexa.so (0x7f9b10b6c000+0xbd31) 
[ 49694.122] 17: /usr/bin/X (0x400000+0xd7c17) [0x4d7c17] 

[ 49694.122] 18: /usr/bin/X (0x400000+0x1674f7) [0x5674f7] 

[ 49694.122] 19: /usr/bin/X (miCompositeRects+0x7a) [0x5675ea] 

[ 49694.122] 20: /usr/bin/X (0x400000+0xd06f0) [0x4d06f0] 

[ 49694.122] 21: /usr/bin/X (0x400000+0x2d201) [0x42d201] 

[ 49694.122] 22: /usr/bin/X (0x400000+0x2131e) [0x42131e] 

[ 49694.122] 23: /lib/libc.so.6 (__libc_start_main+0xfd) 
[ 49694.122] 24: /usr/bin/X (0x400000+0x20ec9) [0x420ec9]

So I thought I'd try the nvidia binary driver. At the first sight fonts 
look different, much larger (and although I don't know why a driver 
change should result in bigger fonts, I can tweak this later) but for 
some reason KDE now tells me this:
The audio playback device HDA Intel (CONEXANT Analog) does not work.
Falling back to .
Which results in no sound working at all. When I try running alsamixer, 
I get the following:
cannot open mixer: No such file or directory
When I try to switch to one of the virtual terminals (e.g. Ctrl+Alt+F1), 
alsamixer runs fine, when I switch back to X, it fails again, so clearly 
nvidia messes with that somehow. I'm unable to find anything relevant in 
the log files but I probably just don't know what to look for.

At this point I don't really care which driver to choose (although I'd 
probably prefer a solution based on nouveau) but please, does anyone 
have a suggestion what to try to have both stable X.org and working sound?

Thank you. Ondřej Kučera

Ondřej Kučera

More information about the arch-general mailing list