[arch-general] mpd fails to start

Madhurya Kakati mkakati2805 at gmail.com
Fri Jun 10 12:47:42 EDT 2011

Recently mpd has stopped working. It doesn't start up at boot and when i
run "rc.d start mpd" I get this error /etc/rc.d/mpd: line 6: 24502
Aborted                 /usr/bin/mpd /etc/mpd.conf &>/dev/null.
I am using gnome3(if thats somehow causing the problem.) I believe its
due to some ALSA pulseaudio mixup but I am not sure.
However if I run "sudo mpd" I get this output:
[papul at papuldesktop ~]$ sudo mpd
output: No "audio_output" defined in config file
output: Attempt to detect audio output device
output: Attempting to detect a alsa audio device
output: Successfully detected a alsa audio device

and after that if I run "mpc play" I get this:
[papul at papuldesktop ~]$ mpc play
Metallica - The Unforgiven II
[paused]  #4/8   0:00/6:36 (0%)
volume: n/a   repeat: off   random: off   single: off   consume: off
ERROR: problems opening audio device

Please help coz I haven't been able to listen to music for quite
sometime now. :(

More information about the arch-general mailing list