[arch-general] On deprecation of net-tools

Magnus Therning magnus at therning.org
Fri Jun 10 20:26:18 EDT 2011

With the recent deprecation of net-tools I did notice some changes:

- The binary 'hostname' now accepts remarkably few options,
  specifically 'hostname -d' no longer works.
- The command 'dnsdomainname' disappeared.  (I'm not really sure why I
  ended up using it though, since 'hostname -d' would have worked just
  as well.)

I have read FS#24647 already, so I'm aware that some of this is being
worked on.  What I'm wondering is, what can I do in the meantime to
get 'hostname -d' back?

Magnus Therning                      OpenPGP: 0xAB4DFBA4 
email: magnus at therning.org   jabber: magnus at therning.org
twitter: magthe               http://therning.org/magnus

Most software today is very much like an Egyptian pyramid with
millions of bricks piled on top of each other, with no structural
integrity, but just done by brute force and thousands of slaves.
     -- Alan Kay
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://mailman.archlinux.org/pipermail/arch-general/attachments/20110611/9d4428a3/attachment.asc>

More information about the arch-general mailing list