[arch-general] Ethernet stopped working after update

Axilleas P markeleas at gmail.com
Mon Jun 27 02:37:33 EDT 2011

On Mon, Jun 27, 2011 at 2:32 AM,  <dmbuce at gmail.com> wrote:
> On 06/26/2011 06:17 PM, Philipp Überbacher wrote:
>> Excerpts from dmbuce's message of 2011-06-27 01:03:06 +0200:
>>> On 06/26/2011 02:50 PM, Javier Vasquez wrote:
>>>> On Sun, Jun 26, 2011 at 1:05 PM,<dmbuce at gmail.com>   wrote:
>>>>> My card:
>>>>> # lspci | grep -i ethernet
>>>>> Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI
>>>>> Express Gigabit Ethernet controller (rev 03)
>>>>> After doing pacman -Syu, ethernet on my desktop stopped working. The
>>>>> card on
>>>>> my laptop is the same, at least according to lspci, and is working
>>>>> fine.
>>>>> When I upgraded, there was a change in syntax in rc.conf for defining
>>>>> the
>>>>> network, but I'm just attempting dhcp for now before I try to set up a
>>>>> static ip:
>>>>> interface=eth0
>>>>> address=
>>>>> netmask=
>>>>> gateway=
>>>>> I've tried resetting the router and switching from the kernel's r8169
>>>>> driver
>>>>> to the r8168 driver from the aur. I compiled the aur driver on my
>>>>> laptop and
>>>>> transferred to the desktop on usb -- as long as they're both x86_64,
>>>>> this
>>>>> shouldn't be a problem, right?
>>>>> Regardless of my choice of driver, ethernet on the laptop works fine,
>>>>> and
>>>>> doesn't work at all on the desktop. If I set up ethernet manually using
>>>>> ifconfig to define the address/netmask/broadcast/etc (making sure the
>>>>> routes
>>>>> are correct), everything appears to work fine until I try to ping the
>>>>> router
>>>>> and get "Destination Host Unreachable".
>>>>> And the kicker is that the light on the router for the port I have my
>>>>> ethernet cable plugged into will light up for the laptop, but not the
>>>>> desktop. Given this and the other behavior, I'm inclined to think it's
>>>>> a
>>>>> hardware issue, but this hardware is only several months old, and
>>>>> having
>>>>> this happen right after an upgrade seems unlikely to be a coincidence.
>>>>> Anything else I can try short of reinstalling or getting a replacement
>>>>> from
>>>>> the manufacturer?
>>>> I'm using netcfg, and haven't found problems so far with all
>>>> changes...  The daemon is net-profiles, and you can copy the example
>>>> for static wired profile into a valid profile, and setup rc.conf
>>>> accordingly.
>>>> See:
>>>> https://wiki.archlinux.org/index.php/Netcfg
>>> How odd. Every other method I've tried for setting up a static IP
>>> succeeds (but doesn't actually get me a working connection). Netcfg
>>> gives me this:
>>> root at bender:~# cat /etc/network.d/ethernet
>>> CONNECTION='ethernet'
>>> DESCRIPTION='Ethernet'
>>> INTERFACE='eth0'
>>> IP='static'
>>> ADDR=''
>>> GATEWAY=''
>>> DNS=('')
>>> root at bender:~# netcfg ethernet
>>> :: ethernet up
>>>   [BUSY]
>>>   >  No connection
>>>    [FAIL]
>>> root at bender:~#
>>> Doing 'sh -x netcfg ethernet' shows that it's printing 'No connection'
>>> from '/usr/lib/network/connections/ethernet up ethernet' on this snippet:
>>>      if ! checkyesno "${SKIPNOCARRIER:-no}"&&  ip link show dev
>>> "$INTERFACE" | fgrep -q "NO-CARRIER"; then
>>>          sleep ${CARRIER_TIMEOUT:-2} # Some cards are plain slow to come
>>> up. Don't fail immediately.
>>>          if ip link show dev "$INTERFACE" | fgrep -q "NO-CARRIER"; then
>>>              report_iproute "No connection"
>>>          fi
>>>      fi
>>> And if I bring up the connection with the old rc.conf syntax, 'ip link
>>> show dev eth0' indeed shows:
>>> 2: eth0:<NO-CARRIER,BROADCAST,MULTICAST,UP>  mtu 1500 qdisc pfifo_fast
>>> state DOWN qlen 1000
>>>      link/ether 00:30:67:8f:7c:a8 brd ff:ff:ff:ff:ff:ff
>>> Which maybe means something to someone. ;)
>>> At this point, I'm ready to chalk it up to the hardware. I can reboot my
>>> laptop, and the light on the router that indicates that it sees the
>>> ethernet cable will only turn off for a second here and there throughout
>>> the shutdown/boot process. I do the same with this machine, and don't
>>> see so much as a flicker. I tried downloading and booting from an ubuntu
>>> live cd and didn't have any luck getting a connection. And both of my
>>> machines are using the same NIC (at least according to lspci), and
>>> should be at roughly the same version of the applicable software -- I
>>> updated my laptop an hour, at most, before I updated my desktop.
>> Did you try running dhcpcd manually after boot? I'm new to netcfg and
>> thought it's normal behavior that I have to launch dhcpcd afterwards..
> Well, I was trying to set up a static connection, so dhcpcd shouldn't be
> needed. But I've set up dhcp connections before with netcfg that launch
> dhcpcd connections automatically. Maybe you could post your config (in a new
> thread, preferably, so as not to hijack this one).

If you insist on setting the static ip, try to write down your dns in

(\_ /) copy the bunny to your profile
(0.o ) to help him achieve world domination.
(> <) come join the dark side.
/_|_\ (we have cookies.)

More information about the arch-general mailing list