[arch-general] Display issues with Linux 3.1

hollunder at lavabit.com hollunder at lavabit.com
Sun Nov 13 11:18:05 EST 2011

> hollunder at lavabit.com, Sat 2011-11-12 @ 22:42:57-0500:
>> I'm rather sure this is a new intel driver bug, I have the exact same
>> issue. My laptops chipset is slightly newer:
>> 00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960
>> Integrated Graphics Controller (primary) (rev 03)
>> 00:02.1 Display controller: Intel Corporation Mobile GM965/GL960
>> Integrated Graphics Controller (secondary) (rev 03)
> I finally figured out a fix for the blank screen during boot issue. I
> had not added i915 to the MODULES list in my mkinitcpio.conf, because
> later in the boot process, udev would kick in and load the driver
> automatically. But apparently this can cause a sort of race condition,
> where if modules happen to be loaded in a particular order by udev, this
> blank screen issue can occur. Loading the driver during early userspace
> avoids this problem entirely, since by the time udev starts up, the
> module has already been present in the kernel for a while.
> So if you don't already have i915 in MODULES, just add it and then
> regenerate your initial ramdisk. This seems to have solved the problem
> for me.
> I was inspired by a suggestion [1] in a bug report on freedesktop.org,
> which led me to this solution. The bug report is for a similar (but not
> identical) issue. The user reported that building a kernel with the i915
> driver statically included made his problem disappear. I tried this, and
> it worked. But this has essentially the same effect as including the
> module in the initial ramdisk, which is a bit easier to do. So there you
> go.
> [1] https://bugs.freedesktop.org/show_bug.cgi?id=22674#c11

Thanks Taylor,
I still consider this a bug because this didn't happen for years but seems
to happen every time I boot since 3.1.

Another workaround is to disable kms by booting with the nomodeset option.

Another new issue is that my mousepointer frequently flickers/disappears
and that xv video out in smplayer doesn't work anymore, but both of those
are with the nomodeset option, have yet to test with kms enabled again.

More information about the arch-general mailing list