[arch-general] Application stability problems (kernel 3.1, Intel hardware)

Ciprian Dorin Craciun ciprian.craciun at gmail.com
Fri Nov 18 11:48:02 EST 2011

On Fri, Nov 18, 2011 at 18:34, David C. Rankin
<drankinatty at suddenlinkmail.com> wrote:
> On 11/18/2011 09:41 AM, Ciprian Dorin Craciun wrote:
> [...]
>  If I catch anything useful in the logs, I'll pass it along...
>  For your specific issues:
>>      Strange behaviour:
>>      * Firefox crashes randomly (or takes the CPU to 100%); (no error on
>> stderr;)
>>      * All OpenSSL based programs complain from time to time of invalid
>> received data;
>>      * Flash makes strange noises, strange display artefacts, usually
>> just crashes;
>>      * mouse jumps in the upper left corner (or sometimes just stays at
>> top or left);
>>      * nothing strange in dmesg;
>  This all looks "Desktop" related (except the SSL invalid received data).
> Have you tried another desktop? (i.e. fluxbox, openbox, gnome, kde, etc..)
> If you are using either kde4 or gnome shell, they are both under heavy
> development and I wouldn't put it past being a desktop issue.

    Thanks David for the feedback.

    I haven't tried any other desktop environment -- and don't have
time to fiddle around with them. But still my desktop environment is
**very minimal**:
    * Window Manager -- i3wm;
    * terminal -- urxvt with screen;
    * no XDM, no PulseAudio, (only local DBus), no NetworkManager, no thrills;
    * pretty much a heavily trimmed down ArchLinux; (actually except
the minimum necessary daemons to run the system (i.e. udev,
wpa_supplicant, dhcpcd, agetty) and some stable userspace tools (i.e.
ssh-agent, gpg-agent) there isn't much else; I've weeded out
everything I don't necessarily need...)

    As such I'm not sure where to "point" the "blame". Aaa... It seems
that Firefox still crashes even with 2.6.38. But the other problems I
haven't encountered... So I blame Firefox for itself dying, maybe i3wm
for the mouse thinggy (which if I restart X is solved), but for the
OpenSSL stuff?


    P.S.: 3.1.0 was **very very very** unstable for me... It just
froze in a matter of minutes... (Not even SysRq+O doesn't solve the

More information about the arch-general mailing list