[arch-general] cannot generate enough entropy for pacman-key --init

Karol Blazewicz karol.blazewicz at gmail.com
Sat Oct 15 12:09:51 EDT 2011

On Sat, Oct 15, 2011 at 5:56 PM, Alper Kanat <tunix at raptiye.org> wrote:
> Hey There,
> I have an Arch Linux box inside Virtualbox on a Mac that I use for
> development purposes. I connect to this machine via SSH without any visual
> interface. It's on [testing] and just upgraded to pacman 4.0 and after
> installation it asked me to run pacman-key --init to generate the necessary
> keys for my system. I did all of these inside GNU Screen (also tried without
> it without any luck):
> $ sudo pacman-key --init
> gpg: Generating pacman keychain master key...
> Not enough random bytes available.  Please do some other work to give
> the OS a chance to collect more entropy! (Need 300 more bytes)
> I pressed random bits with the keyboard but it didn't work so I fired up
> another window inside screen and did cat /dev/urandom > /dev/null but that
> also didn't work. So I found this [1] article and tried it again without any
> luck.
> So I'm basically stuck here. Can someone please help me? Since pacman is
> bricked, I can't also install anything. Now I have to manually downgrade
> pacman if I can't succeed.
> Thanks!
> [1] http://www.thingy-ma-jig.co.uk/blog/22-01-2010/generate-entropy-gnupg
> ---
> Quis custodiet ipsos custodes?

Have you tried just moving your mouse around?

More information about the arch-general mailing list