[arch-general] zsh and ssh just fills my RAM, not doing anything else

Tom Gundersen teg at jklm.no
Sat Oct 29 12:18:42 EDT 2011

On Sat, Oct 29, 2011 at 6:04 PM, Tom Gundersen <teg at jklm.no> wrote:
> 2011/10/29 Rasmus Steinke <rasi at xssn.at>:
>> On 29.10.2011 12:38, Lukáš Jirkovský wrote:
>>> On 29 October 2011 11:41, Rasmus Steinke <rasi at xssn.at> wrote:
>>>> I have a very nasty problem, which started around the time, arch changed
>>>> its
>>>> locale configuration.
>>>> i cannot use ssh in a zsh session. All it does is filling my RAM until
>>>> the
>>>> computer stalls.
>>>> If i run the very same ssh command in a bash session, all is working
>>>> fine.
>>>> I tried with blank config files too - here it gets even more odd.
>>>> With a blank config file it has the same problem in gnome-terminal, but
>>>> suddenly works in urxvt.
>>>> This is very annoying, since i dont like bash too much, but i am forced
>>>> to
>>>> use it now.
>>>> Also i  have absolute NO plan where to start searching for this issue.
>>>> Regards, Rasi
>>> Did you read the news?
>>> http://www.archlinux.org/news/initscripts-update-manual-intervention-required/
>> I didnt mention the locale config without a reason. And yes, i have a
>> locale.conf file.
>> And as i said. with an empty zsh config it works at least in ONE terminal.
> Please open a FS. I'm also using zsh, but cannot reproduce this.

On second thoughts, it might be fixed in git. Could you please try
replacing your /etc/profile.d/locale.sh with:



More information about the arch-general mailing list