[arch-general] ejecting after cdparanoia

Joerg Schilling Joerg.Schilling at fokus.fraunhofer.de
Wed Sep 14 04:44:05 EDT 2011

Jorge Almeida <jjalmeida at gmail.com> wrote:

> I just used cdparanoia (for the very first time) and I tried to eject
> the CD by pressing the button. Nothing happens. I can eject the CD
> with "eject /dev/sr0", so it's not really a big problem. I just wonder
> whether this behavior is normal. I'm used to cdda2wav (from cdrtools),
> and it never happened, that I recall. Note that cdparanoia ended
> normally ( and successfully, BTW).  I run it with speed 1. The drive
> is:

cdparanoia is a cdda2wav version from 1997 with some modifications. Cdparanoia 
is Linux/gcc only.

There modifications are a layer on top of the read functions and below the
data outout. 

As the cdparanoia development stopped in 2001, Heiko Eißfeldt and I took the 
paranoia extensions, converted them to a portable library (libparanoia) and 
enhanced the modern cdda2wav code with the features from libparanoia. As 
cdda2wav uses a better base of read functions (special [vendor tailored] SCSI
functions instead of calling the simplified kernel CDDA audio functions), 
cdda2wav gives beter results than cdda2wav. 

I recommend to use cdda2wav for best audio extraction results and in order to 
be able to access meta data also.

See man page on how to enable paranoia mode in cdda2wav.


 EMail:joerg at schily.isdn.cs.tu-berlin.de (home) Jörg Schilling D-13353 Berlin
       js at cs.tu-berlin.de                (uni)  
       joerg.schilling at fokus.fraunhofer.de (work) Blog: http://schily.blogspot.com/
 URL:  http://cdrecord.berlios.de/private/ ftp://ftp.berlios.de/pub/schily

More information about the arch-general mailing list