[arch-general] USB mounted into "wrong" directory

Vladimir Lomov lomov.vl at gmail.com
Tue Apr 3 22:46:21 EDT 2012

after system upgrade (seems after 2012-04-02) all USB flashes are
mounted in /run/media/USER/LABEL instead of /media/LABEL that was
previously. Is it intentional or is it a bug?

Detailed information:
OS: Archlinux x86_64
Repos: testing
Rel. soft:
       udev                181-9
       systemd             44-4
       libsystemd          44-4
       initscripts-systemd v44.1-1
       udisk               1.0.4-3
       udisk2              1.93.0-1

The following packages (mentioned above) have been updated:
udev                 181-5      -> 181-9
libsystemd           44-1       -> 44-3        -> 44-4
udisk2               N/A        -> 1.93.0-1
systemd              44-1       -> 44-3        -> 44-4
initscripts-systemd  v38-2      -> v44-1       -> v44-2  -> v44.1-1
systemd-arch-units   20120317-1 -> 20120401-1
udisks               1.0.4-2    -> 1.0.4-3

How I mounting USB flash

I run Openbox with autostarted dbus and consolekit (my user added to
group 'storage'), I run pcmanfm or thunar or nautilus, plugin USB mounting
it clikcing on label on left.

P.S. Interestingly, mounting in Dolphin works as usual (flashes are
mounted in /media/LABEL).

WBR, Vladimir Lomov

Nowlan's Theory:
	He who hesitates is not only lost, but several miles from
	the next freeway exit.

More information about the arch-general mailing list