[arch-general] Install problem

Fons Adriaensen fons at linuxaudio.org
Fri Dec 28 09:43:00 EST 2012

On Fri, Dec 28, 2012 at 11:38:15AM +0100, Rodrigo Rivas wrote:
> Do you see the partitions from the emergency shell, doing a `ls /dev/sd*`?

There are no /dev/sd* 

Meanwhile I've noticed something new.

Once in the about ten times I tried booting, it actually worked
(and systemd seems to be incredibly fast). 

In the other cases, there's an oops:

Booting the kernel.
:: running early hook [udev]
:: running hook [udev]
:: Triggering uevents...
[   0.870155] BUG: unable to handle kernel NULL pointer dereference at 00000010
[     ....  ] IP [<f81f1240>] pacpi_set_dmamode+0x50/0xa0 [pata_acpi]
[     ....  ] *pde = 00000000



The same thing can happen when booting from the install media, but it
seems less likely (one time in three or four).

Looks like some race condition.

I scanned the BIOS for any relevant options, but the only thing I 
found was an option to enable/disable 'legacy SATA0 support'. It
doesn't seem to make any difference.
> Can you paste the contents of the syslinux.cfg file?

I could if you really need it, but it's the unmodified one 
as installed. I checked it as suggested by the install guide,
but didn't find anything to change.



A world of exhaustive, reliable metadata would be an utopia.
It's also a pipe-dream, founded on self-delusion, nerd hubris
and hysterically inflated market opportunities. (Cory Doctorow)

More information about the arch-general mailing list