[arch-general] Glibc 2.16 bad effect on some software ?

Bjørn Øivind Bjørnsen bo.bjornsen at gmail.com
Fri Jul 6 06:37:18 EDT 2012

On 06/07/12 12:23, Paul Gideon Dann wrote:
> On Thursday 05 Jul 2012 17:01:37 you wrote:
>> On Thursday 05 Jul 2012 16:10:26 you wrote:
>>> I'll rebuild Qt when I have a spare moment.  It doesn't seem to affect
>>> Assistant or other Qt apps, though.
>> Qt fails to compile with the following backtrace; it appears glib is at
>> fault:
> This suggestion seems to fix this:
> http://www.qtforum.org/article/37809/error-union-tag-used-in-naming-struct-
> gmutex.html
> I created a bug report:
> https://bugs.archlinux.org/task/30563
> However, I still can't build Qt, because of another issue:
> compiling helpviewer_qwv.cpp
> <snip>
> make: *** [sub-tools-make_default-ordered] Error 2
> This has all happened at a most inopportune time :(
> Paul


This looks a lot like the error I got the last time I tried to build Qt.
Try building Qt using the "testing-x86_64-build" or "extra-x86_64-build"
(obviously your architecture may vary) wrappers, they set up a clean
chroot for you to build in. This approach worked for me.

Some more info can be found here:

Bjørn Øivind

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 900 bytes
Desc: OpenPGP digital signature
URL: <http://mailman.archlinux.org/pipermail/arch-general/attachments/20120706/381b18dd/attachment.asc>

More information about the arch-general mailing list