[arch-general] problems with wifi b43 (broadcom)

Thanos Zygouris athanasios.zygouris at gmail.com
Tue Jul 17 10:11:41 EDT 2012

On Tue 17 Jul 10:00, Leonidas Spyropoulos wrote:
> This is weird.. I did same steps, installed aur package for firmware. I
> installed the arch on the laptop on Friday. Vanilla kernel.

I read your kernel logs and found that you used an encrypted
wireless connection. So I changed my wireless connection to encrypted
too (WPA2-PSK) and I couldn't authenticate or get any IP too.
So, I removed the b43-firmware package, installed the broadcom-wl
rebooted and tried wl instead. It worked.

I found here[1] (we have the 14e4:432b PCI-ID) that our wifi card is 
partially supported by the b43 driver. I'll stay for some time with 
the proprietary broadcom-wl and see what happens. (It's a shame tho, 
cause it's the only non-open source package in my system)


P.S.:Sorry again for the wrong info, i have to be more careful in the

More information about the arch-general mailing list