[arch-general] Suspend to ram and uresume hook for systemd

Myra Nelson myra.nelson at hughes.net
Mon Jul 30 03:08:15 EDT 2012

Since I'm still wading my way through some of the intricacies (read
small details) and in view of the recent discussion on libcrypt,
keysize, key values, and systemd;

I've been using uswsusp-git from the aur and s2ram -f for my suspend
command. /etc/suspend.conf has /dev/snapshot and /dev/sda4 (swap) for
the image. Suspension and reboot have been working fine. After
rebuilding my initramfs image with the uresume hook, when I tried to
reboot today the boot process hung at waiting for libgcrypt. In my
infinite wisdom, after testing the suspend and reboot several times
before using the uresume hook, I had uresume in both images. I don't
use encrypted volumes and never have. I chrooted in and rebuilt the
initramfs image without the uresume hook, rebooted, and everything
worked great.

I tried using systemctl suspend from the wiki article. The machine
goes down but won't come back up without a complete restart, fsck
volumes that were not cleanly unmounted, etc. Since this is a desktop,
I really don't need the suspend option, it's just nice to save a
little electricity.

The systemctl shutdown and sytemctl reboot work great. I admit to not
having done a lot of research but based on the recent discussions and
changes with systemd, does anyone know what caused this hiccup?


Life's fun when your sick and psychotic!

More information about the arch-general mailing list