[arch-general] pkgbuild depends() can you have both >= <=?

Magnus Therning magnus at therning.org
Tue Jul 31 00:53:34 EDT 2012

On Mon, Jul 30, 2012 at 08:16:28PM -0500, David C. Rankin wrote:
> Guys,
>   Is it possible to have both a 'greater than' and 'less than' dependency on any
> single package listed as a depends in a PKGBUILD?  I want to specify gegl
> >=0.1.8 and <=0.2 for gimp26. Possible?
>   Man page says:
> <quote>
> Entries can also include a version requirement of the form name<>version, where
> <> is one of five comparisons: >= (greater than or equal to), <= (less than or
> equal to), = (equal to), > (greater than), or < (less than).
> </quote>
>   Where the operative phrase is: 'is one of five...'
>                                      ^^^
>   Can you list a depends twice? (i.e.: gegl>=0.1.8 gegl<=0.2)

Yes, and they have to be listed just like you did above, i.e. as two
separate depends.


Magnus Therning                      OpenPGP: 0xAB4DFBA4 
email: magnus at therning.org   jabber: magnus at therning.org
twitter: magthe               http://therning.org/magnus

I invented the term Object-Oriented, and I can tell you I did not have
C++ in mind.
     -- Alan Kay
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://mailman.archlinux.org/pipermail/arch-general/attachments/20120731/8c7d3d01/attachment.asc>

More information about the arch-general mailing list