[arch-general] Restarting at-spi2?

Ray Kohler ataraxia937 at gmail.com
Sun Nov 11 21:25:03 EST 2012

On Sun, Nov 11, 2012 at 3:37 PM, kendell clark <coffeekingms at gmail.com> wrote:
> hi all
> I am currently using orca v3.6.1 on xfce 4.10. Occasionally orca will crash
> causing me to have to restart it. This will sometimes also crash the at-spi2
> bridge, causing orca to restart but then refuse to read anything on the
> screen until i reboot. I've tried to track down the processes responsible
> for at-spi. Typing ps -e | grep -i at-spi gives me two processes.
> at-spi2-dbus-launcher and at-spi2-registryd. I tried to write a script to
> restart at-spi2 by simply killall -9 at-spi2-dbus-launcher and
> at-spi2-registryd, then restarts them. but I get a command not found error
> when trying to restart both of them. Knowing nothing about dbus, I'm lost
> here. can anyone help? I've tried looking at the
> .config/autostart/at-spi2-registryd file provided with xfce, but it doesn't
> have the command I need to start  at-spi2.  I've researched on the web, but
> haven't found anything promising, only old bug reports that have been
> closed, and some forum posts, also about old bug reports. my search term was
> "restarting at-spi2."
> Any help/documentation/manpages are greatly appreciated.

I looked at the contents of the at-spi2-core package, and found that
at-spi-bus-launcher and at-spi2-registryd are located in directory
/usr/lib/at-spi2-core/ . As that's not in your path, you'll get
"command not found" trying to run them by their simple names. Use
their full paths when running them. In any case, the desktop autostart
file for at-spi is at /etc/xdg/autostart/at-spi-dbus-bus.desktop , and
it shows the normal startup command to be:
/usr/lib/at-spi2-core/at-spi-bus-launcher --launch-immediately

More information about the arch-general mailing list