[arch-general] File permissions with udisks/udisk2 mounts

Paul Marwick paul.marwick at gmail.com
Thu Nov 22 17:31:10 EST 2012

Curtis Shimamoto wrote:

> Have you tried manually mounting with something like:
> # mount -o exec /dev/whatever /mount/point
> I don't use udisks, but I use pmount and (I think) it automatically
> mounts with the noexec option. I have never had a reason to try to get
> around this, so I also cannot speak to whether or not working around it
> is functional.

Thanks for the suggestion. I hadn't tried that, though I had tried 
pmount with the -e flag, which should set executable permissions.

Mounted as you suggest, the script is executable. :) It failed again, 
but that was because I didn't have mtools installed, and was easy to 
fix. Interesting that a manual mount worked where pmount and mount using 
'noauto' in /etc/fstab didn't.

> But I figure if you do it manually, and specify exec, if it still
> doesn't work, then you at least then know that it is not specific to any
> of these automounting functions you use.
:) I guess it proves that it is down to udisks/polkit. I'd still like to 
know how I can control the options set by them, but at least your 
suggestion allows me to do what I need. Thanks again.


More information about the arch-general mailing list