[arch-general] issues with netcfg v3.0 whe installing archlinux

kendell clark coffeekingms at gmail.com
Sat Nov 24 17:27:50 EST 2012

Hi all
I'm not sure how, but I broke my archlinux installation on my internal 
hard drive. But I have the arch-installation scripts on my usb arch 
install, so I'm installing arch back on to my hard drive. Everything 
goes fine until it gets to the point where I set up the network from 
within the chroot. I run wifi-menu, which works fine, I select my 
network, family_network, enter the wpa2 key, and wait. Sometimes it will 
connect, and sometimes it will give me one of two error messages. 
Either, ip lease attempt failed, or failed to connect. In either case I 
select not to keep the generated profile, and try again. If it does 
connect, the internet works fine with a ping to google.com, but if I 
touch either the pacman mirrorlist file, or configure pacman in 
pacman.conf, and run a pacman -Syy, pacman errors out with a, failed to 
retrieve reponame, download library error. I'm stumped. I've varified 
that I have the correct wpa passphrase, and that my internet functions 
normally. If I exit the chroot, reboot and chroot back in it will work 
for a little while, then go out again with the same error.
Am I missing something obvious? or is it an issue with my usb install? 
If I try this from the arch iso I downloaded in july, it works. but I 
can't easily consult the beginner's guide from the console which is why 
I don't use it.
Thanks for any help and sorry for the long message.

More information about the arch-general mailing list