[arch-general] problem with realtek 8192cu usb wireless card

Xeslaro bfsc.yb at gmail.com
Sun Sep 2 00:50:16 EDT 2012

On Sat, Sep 01, 2012 at 01:57:26PM +0600, Kirill Churin wrote:
> Hello, for the free driver, it's stated that non-free firmware must be
> present for this card: http://wiki.debian.org/rtl819x#Drivers
> I can't find it in the Arch repos, so you can download debian's
> package and put firmware in it's location  yourself ugly way (or make
> package of it and push it to AUR).
> As of non-free drivers, you can check AUR
> https://aur.archlinux.org/packages.php?O=0&K=8192&do_Search=Go and try
> this packages, maybe some will work.
> -- 
> Kirill Churin
> Jabber: reflexing at reflexing.ru

  thanks for the information, i changed the kernel to 3.5.3 and saw this card is supported and found the firmware you mentioned in my arch distro, everything seems working fine, however wpa_supplicant wouldn't pass the 4 way handshake state and reports the pre-shared key isn't correct while the same configuration file for wpa_supplicant worked for another wireless card, also, when using iw to create an ibss cell no error is reported but actually it isn't created, and after exiting from wpa_supplicant the card couldn't get anying result via iw scan, i must unplug it and plug it again to get scanning results...

  i tried kernel 3.5.3 and the most recent one from git, also tried the official driver from realtek on 3.2.6 and, none is at least working...

  just wanna forget all the mess after reporting something to the wireless.kernel.org mailing list.

More information about the arch-general mailing list