[arch-general] / mounted ro after update

P .NIKOLIC p.nikolic1 at btinternet.com
Tue Sep 18 09:26:54 EDT 2012

On Tue, 18 Sep 2012 12:07:55 +0100
Kevin Chadwick <ma1l1ists at yahoo.co.uk> wrote:

> > all disc ID's are correct  so what has been screwed up this was
> > perfect until the update  or am i going to be forced to
> > re-install   not an option i look forward to 
> A workaround rather than a fix but may help investigate or fix the odd
> machine. Have you tried switching out the
> UUID=a1439104-fcea-4c90-b0fb-2340154a9eae for /dev/sda3 in fstab? 

Hi Kevin

No i have not tried that yet  but i have found something  that seems to
point to an ext4 fs problem  . 

If i shut the machine down after it has been running ok  and all
mounted correctly rw  then reboot it will always come up dev/sda4
mounted ro    , But if i boot from the latest arch cd  and fsck.ext4
both sda3 and sda4 it will reboot fine all mounted rw again .

I am getting no reports of disc problems at all  makes me think it is
both kernel and util-linux at fault as that is when it all started
when both were updated

Pete .

Linux 7-of-9 3.5.3-1-ARCH #1 SMP PREEMPT Sun Aug 26 09:14:51 CEST 2012
x86_64 GNU/Linux

More information about the arch-general mailing list