[arch-general] Problem with radeon driver

Fons Adriaensen fons at linuxaudio.org
Wed Sep 19 16:41:26 EDT 2012

On Wed, Sep 19, 2012 at 01:27:30PM -0300, Martín Cigorraga wrote:

> Which ATi card does your system have?

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Radeon RV250 [Mobility FireGL 9000] (rev 02) (prog-if 00 [VGA controller])
        Subsystem: IBM Device 0531
        Flags: bus master, stepping, fast Back2Back, 66MHz, medium devsel, latency 66, IRQ 10
        Memory at e0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at 3000 [size=256]
        Memory at c0100000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at c0120000 [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2

> My laptop have this[0] and here is my /etc/X11/xorg.conf (I haven't
> splitted it yet): http://pastebin.com/jc2tfRPT.


I solved the error by ensuring that intel_agp gets loaded before
radeon. This is actually mentioned in the wiki but I didn't notice
it at first. But that didn't make any difference for the X11 results.

I got X11 working by disabling KMS (kernel option 'nomodeset').
Still strange, since the original system worked fine with 'late'
KMS enabled. The only difference (apart from all the updates) is
that I replaced grub-legacy by syslinux.



A world of exhaustive, reliable metadata would be an utopia.
It's also a pipe-dream, founded on self-delusion, nerd hubris
and hysterically inflated market opportunities. (Cory Doctorow)

More information about the arch-general mailing list