[arch-general] failed to mount root on raid1 after upgrade

Łukasz Michalski lm at zork.pl
Tue Apr 2 14:43:05 EDT 2013

W dniu 4/2/2013 7:40 PM, Curtis Shimamoto pisze:
> On 04/02/13 at 09:54am, Łukasz Michalski wrote:
>> Hi,
>> I am a new arch user and this is my first post on this list, so
>> welcome everyone :-)
>> 29th I upgraded my system using pacman -Syu and after that my system
>> does not boot.
>> The problem is that I have root partition on software raid1 and for
>> some reason scripts from initramfs are not able to create /dev/md
>> device and mount it on /new_root.
>> I am using mdadm hook.
> Have you tried using the mdadm_udev hook?  I think this is the better way
> to go.  In my experience in the past, it was certainly the faster more
> reliable hook.

Yes, I tried, but effect was the same. I only checked it once and 
reverted back to mdadm hoping that would be easier to make work 
something that was already working in the past.


More information about the arch-general mailing list