[arch-general] mysqld (MySQL and MariaDB) polling

Leonidas Spyropoulos artafinde at gmail.com
Tue Feb 26 04:39:45 EST 2013

On 25 Feb 2013 15:40, "Christian Hesse" <list at eworm.de> wrote:
> Hello everybody,
> based on the thread "[RFC] Migration to MariaDB" in arch-dev-public by
> Bartłomiej Piotrowski I started playing with MySQL and MariaDB. I noticed
> both were polling every second:
> <... futex resumed> )       = -1 ETIMEDOUT (Connection timed out)
> futex(0x1d48050, FUTEX_WAKE_PRIVATE, 1) = 0
> gettimeofday({1361806174, 246573}, NULL) = 0
> 2849, {1361806175, 246573000}, ffffffff <unfinished ...>
> Searching Google I found that the problem may be caused by the leap
> though the load is not as high as some articles describe. (Continues
> vs. one poll a second.)

I had the same problem with an EC2 instance which cost me some pounds.. And
yeah from what I searched as well it probably relevant to the leap second

> However the polling stops as soon as I manually set the time with date -s
> it start again if I run ntpdate to sync the time. As this is a notebook I
> rebooted more than once since the leap second happened. ;)

Mine was fixed when I did the date -s. (And I have done reboot after it.)
Have you tried changing servers for the ntpd? I think there was a bug
report in fedora about it, maybe worth looking for it and check comments.
Also do you update the hwclock?

> What is going on? This is a mobile system, so it would be great to get
rid of
> mysqld eating my battery power.
> --
> main(a){char*c=/*    Schoene Gruesse                         */"B?IJj;MEH"
> "CX:;",b;for(a/*    Chris           get my mail address:
> putchar(b-1/(/*               gcc -o sig sig.c && ./sig

More information about the arch-general mailing list