[arch-general] ACPI: \_SB_.PCI0.LPC_.EC__.BAT1: Unable to dock! (ThinkPad X230/KDE)

Martti Kühne mysatyre at gmail.com
Mon Jul 22 02:28:57 EDT 2013

On Tue, Jul 16, 2013 at 6:34 PM, mert <472114271 at qq.com> wrote:
> Hi,
> I noticed there's alway an 'Unable to dock' error message after suspend
> to RAM:
>     Arch kernel: ACPI: Low-level resume complete
>     Arch kernel: PM: Restoring platform NVS memory
>     Arch kernel: Enabling non-boot CPUs ...
>     Arch kernel: smpboot: Booting Node 0 Processor 1 APIC 0x1
>     CPU1 is up
>     smpboot: Booting Node 0 Processor 2 APIC 0x2
>     CPU2 is up
>     smpboot: Booting Node 0 Processor 3 APIC 0x3
>     CPU3 is up
>     ACPI: Waking up from system sleep state S3
>     ACPI: \_SB_.PCI0.LPC_.EC__.BAT1: docking
>     ACPI: \_SB_.PCI0.LPC_.EC__.BAT1: Unable to dock!
> System info:
> ThinkPad X230i, Linux 3.9.9-1-ARCH, systemd 204-3,
> I have tried to set Handle{SuspendKey,HibernateKey,LidSwitch} all to
> ignore, but I still get the same error message. Any other solution to
> make that message disappear?

Any success with this? A quick google revealed that there is at least
a report of a debian/x230 user with the same problem...

You might try to properly unload and reload thinkpad_acpi with the
hooks so acpi is properly initialized when this is done.
I forgot where to set them up though, since I've only been using these
things before we started using systemd...


More information about the arch-general mailing list