[arch-general] systemd --test

Wayne S linux at zuik.net
Mon Nov 4 10:07:00 EST 2013

my apologies for improperly sending email to list.

My question is how to properly use systemd --test:

>From the website: http://www.freedesktop.org/wiki/Software/systemd/TipsAndTricks/

It suggests to run this to see what would execute on boot for a unit:

# systemd --test --system --unit=multi-user.target

If I run this as root, I get command not found. So it is not in $PATH.

If I run as root I get don't run as root:

# /usr/lib/systemd/systemd --test --system --unit=multi-user.target
Don't run test mode as root.

If I run as user, I get a bunch of errors:

$ /usr/lib/systemd/systemd --test --system --unit=multi-user.target
systemd 208 running in system mode. (+PAM -LIBWRAP -AUDIT -SELINUX -IMA -SYSVINIT +LIBCRYPTSETUP +GCRYPT +ACL +XZ)
Failed to set hostname to <arch-t3400>: Operation not permitted
Failed to open /dev/tty0: Permission denied
Failed to create root cgroup hierarchy: Permission denied
Failed to allocate manager object: Permission denied

Is there a way to use this command properly?


More information about the arch-general mailing list