[arch-general] Kernel freeze on boot with kernel 3.10.x

Nils Becker nilsc.becker at gmail.com
Thu Oct 24 13:32:34 EDT 2013

Am Sun, 1 Sep 2013 22:00:08 +0200
schrieb Martti Kühne <mysatyre at gmail.com>:

> On Sun, Sep 1, 2013 at 1:48 PM, Nils Becker <nilsc.becker at gmail.com>
> wrote:
> > Hello everyone,
> >
> > since kernel version >3.9.x (e.g. 3.10.3, 3.10.10) my system freezes
> > during the boot. I was hoping for a fix to appear in later versions
> > of 3.10. but as this was not the case, I am in dire need of help to
> > debug this problem as currently I am not even getting any logs from
> > the crash.
> >
> > Problem: After grub is loaded the system loads the initial ram disk
> > and I am prompted to enter the password for my root partition.
> > After that the system starts normally (systemd messages) and
> > freezes at some point. The last message printed differs a little
> > bit between boots, but it is roughly about "Mounted Config File
> > System". The freeze is apparently a complete crash: I started a
> > systemd rescue console on tty9 (which startup is printed out) but I
> > cannot switch in that console after the freeze (no response on key
> > events). Apparently the logs are not yet written to the harddisk as
> > I can not find any entries on that boot if I startup another kernel.
> >
> > I would be grateful for any pointers on this issue and/or some
> > suggestions how I can at least get a useful log from the crash to
> > open a bug report.
> >
> > I am using the standard arch linux packages (at least where the
> > bootup is involved). My system is using a raid1 with encrypted root
> > partition. And yes, it works flawlessly if I downgrade the linux
> > package to <3.10.x.
> >
> > My hardware configuration (hwinfo output) can be found under:
> > www.ncbecker.de/pc/hwinfo
> > I ran hwinfo with the lts-kernel.
> Dunno what to do with that, I can't even tell if you're not a HP
> pavillon as in [2].
> As I made sure to fully be clear about with my last kernel problem,
> could you tell us which 3.9.x exactly was the first to break for you?
> I made absolutely sure it was 3.10.6 which was the first that broke
> for me and I found the fix in the arch forums [0], I just believe
> there's quite an importance in knowing this - as it also would shorten
> down bisecting kernel-git quite a bit. Look, similar issues can be
> found in [1], [2] and [3] at least. To be very unfair, seriously, you
> took your time to speak up...
> cheers!
> mar77i
> [0] https://bbs.archlinux.org/viewtopic.php?pid=1319586
> [1] https://bbs.archlinux.org/viewtopic.php?pid=1299482
> [2] https://bugs.archlinux.org/task/34358
> [3] https://bugs.archlinux.org/task/35188

Thanks for your answers!

At the time I wrote the email I was too busy to do the kernel bisect
and needed a working pc. I did it now. (btw: it was introduced with
3.10.0... did a full bisect...)

Turns out the problem was introduced with a patch to the driver of my
tv card. This problem is thus "solved" by unplugging my tv card which I
rarely used anyways ;)

I submitted a bug report and hopefully someone who understands the
offending commit can create a fix:


More information about the arch-general mailing list