[arch-general] [solved] out of memory while allocating z_stream

Stephen E. Baker baker.stephen.e at gmail.com
Sat May 10 11:17:00 EDT 2014

On 2014-05-10 9:24 AM, Stephen E. Baker wrote:
> Hello,
> As of yesterday I cannot boot, regardless of whether I choose the 
> regular or failback kernel from the boot loader.
> I haven't been able to find anything on google, so I was hoping 
> someone here might know what's going on.
> Last time my system was up I installed updates including the latest 
> kernel, and I ran e4defrag over the disk.
> The computer is a ThinkPad T60, with a Core 2 Duo and 2GB of Ram. I am 
> running the i686 version of Arch Linux.
> My boot loader is syslinux.
> In the mean time I'm downloading a new copy of the Arch Install ISO 
> (all my existing recovery disks are too old to chroot from), and I 
> will try reinstalling the kernel.
> Output:
> Loading ../vmlinuz-linux... ok
> Loading ../initramfs-linux.img...ok
> Probing EDD (edd=off to disable)... ok
> early console in decompress_kernel
> Decompressing Linux...
> Out of memory while allocating z_stream
> -- System halted
Alright, I did a couple things at once because I was tired of rebooting 
so I'm not sure which actually fixed it, but it's working now.
I ran the rescue disk in normal mode and did a chroot instead of trying 
to boot into my system.
I deleted the linux kernel from /var/cache/pacman, and installed it over 
I ran syslinux-update_install -u -m

More information about the arch-general mailing list