[arch-general] systemd-run --user does not work

Savyasachee Jha savya.jha91 at gmail.com
Mon May 12 10:23:33 EDT 2014

On Mon, May 12, 2014 at 11:17 PM, Rodrigo Rivas <rodrigorivascosta at gmail.com
> wrote:

> Hello, list!
> This is an issue that has been nagging me for a while, and I thought
> that it was something I did to my machine, until I tested it in
> another Arch installation, and it is all the same.
> The problem is when I run for example:
>  $ systemd-run --user /usr/bin/ls
> Failed to create bus connection: No such file or directory
> I would expect it to run the command and save the output in the
> journal, just as the --system counterpart does.
> You could think that the systemd user daemon is not running properly, but:
>  $ systemctl --user
> works perfectly. Moreover, if I create a user unit as
> ~/.config/systemd/user/test.service and start it with `systemctl
> --user start test` it works, too.
> I know that systemd user sessions are still a bit of experimental, but
> I don't see any reason why systemctl works and systemd-run does not.
> Is this a bug? Or am I missing something?
> --
> Rodrigo

Well, I just tried this out on my laptop, and it gives two different error

$ sysytemd-run --user /usr/bin/ls
Failed to create message: Input/output error

$ sudo systemd-run --user /usr/bin/ls
Failed to create bus connection: Connection refused

And yes, running it with --system works perfectly well. It is very odd.

Savyasachee Jha

*"Aerodynamics is for people whodon't know how to build engines."*

More information about the arch-general mailing list