[arch-general] Virtualbox downgrade - Was: FS#41424 - Virtualbox 4.3.14, USB doesn't work flawlessly

Ralf Mardorf ralf.mardorf at rocketmail.com
Sat Nov 22 13:01:34 UTC 2014


I needed to downgrade again.

Using Windows XP (32 bit) Service Pack 3 as guest, in 2014-10-21 I
upgraded iTunes to and iOS 8.0.2 -> iOS 8.1 to an iPad 2 by an
USB connection.

In 2014-10-28 I upgraded virtualbox 4.3.12-1 -> 4.3.18-1.

This month upgrading iOS 8.1 -> 8.1.1 by an USB connection failed.

So I run

# dkms remove -m vboxhost -v 4.3.18 --all
# downgrade virtualbox virtualbox-host-dkms virtualbox-guest-iso
# pacman -R virtualbox-ext-oracle
# pacman -U /var/cache/aur/virtualbox-extension-pack-4.3.12-1-x86_64.pkg.tar.xz

# dkms install vboxhost/4.3.12 -k 3.14.23-rt20-1-rt
worked :)
# dkms install vboxhost/4.3.12 -k 3.10.58-rt62-2-rt-lts
worked :)

_But_ unfortunately it doesn't work for the current kernel:

# dkms install vboxhost/4.3.12 -k $(uname -r)

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.17.3-1-ARCH -C /usr/lib/modules/3.17.3-1-ARCH/build M=/var/lib/dkms/vboxhost/4.3.12/build........................(bad exit status: 2)
Error! Bad return status for module build on kernel: 3.17.3-1-ARCH (x86_64)
Consult /var/lib/dkms/vboxhost/4.3.12/build/make.log for more information.

I suspect this issue already startet after upgrading 3.16.4-1 ->
3.17.1-1. I upgraded virtualbox 4.3.12-1 -> 4.3.18-1, because building
the modules for the kernel didn't work anymore.

Any ideas how to build the vbox modules for the current linux package?


PS: Now I try upgrading iOS 8.1 -> 8.1.1 using virtualbox 4.3.12-1.
Perhaps virtualbox 4.3.18-1 isn't the culprit, but since I experienced a
few USB issues before, I have good reason to expect that it will solve
the issue.

More information about the arch-general mailing list