[arch-general] Problems using AUR since upgrade of pacman db version

Yaro Kasear yaro at marupa.net
Thu Jan 1 17:43:58 UTC 2015

On 01/01/2015 10:41 AM, Rich wrote:
> On 01/01/2015 10:27 AM, Troy Engel wrote:
>> On Thu, Jan 1, 2015 at 10:12 AM, Geoff <capsthorne at yahoo.co.uk> wrote:
>>> Not intending to contradict, but rebuilding cower worked for me.  I 
>>> used a
>>> clean tarball and did makepackage --skipinteg (see the discussion 
>>> under cower
>>> in the AUR)
>> Same here on multiple systems. The pacman upgrade replaced libalpm.so
>> from .8 to .9, you'll probably need to run 'pacman-db-upgrade', then
>> rebuild/reinstall cower (another thread also mentioned package-query,
>> which backs yaourt). If you're using pacaur there's an update for that
>> as well which adds the prevent-as-root check to align with the new
>> pacman 4.2 restriction.
>> hth,
>> -te
> The procedure described here, 
> https://aur.archlinux.org/packages/package-query/ worked for package 
> -query and pkgbrowser.

yaourt users will need to rebuild package-query as well, even though 
yaourt itself is a shell wrapper.

More information about the arch-general mailing list