[arch-general] keymap corruption

Michael Dahlberg olgamirth at gmail.com
Sun Jan 11 22:44:55 UTC 2015

On January 11, 2015 at 5:36:35 PM, Oliver Temlin (temlin at gmail.com) wrote:
On 11 January 2015 at 21:38, Michael Dahlberg <olgamirth at gmail.com> wrote:  
> I recently had a hard drive failure which resulted in my system having a corrupted /var. I removed /var and recreated it from backups, however now i seem to have a unique problem: when I log into the console the backspace and ESC keys do not function correctly. Both keys just result in advancing the cursor. Strangely, if I boot into the rescue.target, the keys work correctly.  
> Any suggestions will be greatly appreciated.  

Have you tried rebuilding the ramdisk? It usually helps in these cases.  

Thanks for the suggestion.  Yes, I tried re-running mkinitcpio, not because I thought it might help, but because my /var was originally on an lvm2 volume and now it is back on the same filesystem as / and I thought I’d remove lvm2 from the HOOKS.

Unfortunately, it didn’t help.


More information about the arch-general mailing list