[arch-general] run boinc with optirun but no GPU found

Stephen Zhang zsrkmyn at gmail.com
Fri May 1 14:29:10 UTC 2015

Hi all,

Today I installed boinc, and I'd like to run it with `optirun`.

The first time I run `optirun bonic_client --dir /var/lib/boinc`, it showed
me that `No usable GPUs found`. So, I installed `opencl-nvidia` package
from the repo. After `opencl-nvidia` installed, I restart the boinc with
optirun, it showed the same prompt. But after a suspend of my computer,
it worked fine! the prompt became like this:
01-May-2015 11:36:53 [---] CUDA: NVIDIA GPU 0: GeForce GT 620M (driver version unknown, CUDA version 7.0, compute capability 2.1, 1024MB, 1009MB available, 240 GFLOPS peak)
01-May-2015 11:36:53 [---] OpenCL: NVIDIA GPU 0: GeForce GT 620M (driver version 349.16, device version OpenCL 1.1 CUDA, 1024MB, 1009MB available, 240 GFLOPS peak)
And a project began to use GPU to caculate as well.

However, after I reboot my computer, the boinc can't find GPUs any more!
The prompt is always `No usable GPUs found`. I also tried to write a
simple CUDA program[1] to test if my CUDA device was ok, and the result was
the CUDA program worked fine, it printed 'Hello CUDA!' as expected.

My GPU model is NVIDIA GeForce GT 620M as mentioned above. My laptop
model is Acer E1-471G 32352G50Mnks.

I also have bbswitch installed, and `cat /proc/acpi/bbswitch` shows:
0000:01:00.0 ON

And here is the output of `lsmod |grep nvidia`:
nvidia_uvm             73728  0
nvidia               8409088  1 nvidia_uvm
drm                   282624  6 i915,drm_kms_helper,nvidia
i2c_core               53248  8 drm,i915,i2c_i801,drm_kms_helper,i2c_algo_bit,nvidia,v4l2_common,videodev

Anyone knows how I can run boinc with `optirun` correctly, or how I can
run boinc with my GPU?
Any reply will be appreciated!

[1] https://cfp.vim-cn.com/cbSR/c


More information about the arch-general mailing list