[arch-general] pam upgrade and systemd

Troy Engel troyengel+arch at gmail.com
Tue May 19 00:10:40 UTC 2015

Heya all - so I ran a standard upgrade these evening, which upgraded
pam; I was headed for a reboot (since the new 4.0.3 kernel was also
updated) and checked my logs just because; my fcron daemon was failing
before the reboot. Huh.

pacman log:
 [2015-05-18 18:28] [ALPM] upgraded pam (1.1.8-5 ->
1.2.0-1)[2015-05-18 18:28] [ALPM] upgraded pam (1.1.8-5 -> 1.2.0-1)

 May 18 18:28:22 grimm fcron[13534]: PAM unable to
dlopen(/usr/lib/security/pam_unix.so): /usr/lib/libpam.so.0: version
`LIBPAM_MODUTIL_1.1.9' not found (required by
(... followed by lots of broken pipe errors)

So I had rebooted already, which means I could not test further in the
same error state -- but basically, should the pam upgrade have
triggered a reload of systemd? Based on lsof, that's who has this file
held open:

 $ lsof | grep libpam
 systemd   1512      tengel  mem       REG              254,2
60008     141189 /usr/lib/libpam.so.0.84.1

My thought is if this was truly broken, then I would not have been
able to log in if I had not rebooted (pure coincidence I did) since
pam_unix.so was dying; fcron as a daemon doesn't have it open, so I
can only assume it was attempting to do a login (it's cron after all)
to run crontabs, which is systemd running the show.

Anyone have a system they haven't upgraded in ~24hrs to give it a
further test, see if logins are broken after the pam upgrade?


More information about the arch-general mailing list