[arch-general] Mouse buttons not working in X

Ben Oliver benoliver999 at gmail.com
Sun Nov 15 16:58:27 UTC 2015

On 15 Nov 2015 4:56 pm, "Magnus Therning" <magnus at therning.org> wrote:
> I've just updated a sligtly neglected machine I have (not upgraded since
> mid-September). Thanks to the [ARA][1] I managed to upgrade it in weekly
> steps. It all seemed to work fine, and indeed it boots just fine.
> There's only one little thing that's broken: the mouse buttons don't
> work.
> Yes, it's really only the mouse buttons that don't work.  I can move the
> pointer using the mouse.  I can scroll using the scroll wheel.
> Starting `xev` I thought I'd have a look at what actually happens:
> 1. Start `xev`.
> 2. Move the pointer into the window -> the various events scroll by in
> the terminal.
> 3. Press the left mouse button -> no event printed in the terminal.
> 4. Move the pointer in the window -> no events are printed in the
> terminal.
> 5. Change focus to another window using Ctrl-Tab, change back ->
> movements in the `xev` window once again generate events.
> I've tried searching for a solution, but I can't find anything
> resembling this.
> What could be causing this behaviour, and how do I fix it?
> /M
> [1]: https://wiki.archlinux.org/index.php/Arch_Linux_Archive
> --
> Magnus Therning                      OpenPGP: 0xAB4DFBA4
> email: magnus at therning.org   jabber: magnus at therning.org
> twitter: magthe               http://therning.org/magnus
> Goto labels should be left-aligned in all caps and should include the
> programmer's name, home phone number, and credit card number.
>      -- Abdul Nizar

Not to be *that* guy, but have you tried another mouse?

More information about the arch-general mailing list