[arch-general] grub

João Miguel jmcf125 at openmailbox.org
Thu Nov 26 16:31:39 UTC 2015


I use a custom kernel and nvidia-dkms, but tested this with the regular
kernel and nvidia package, and get precisely the same problem(s). As
such, I'm going to try anything with DKMS and the custom kernel, so I
don't need to be switching back and forth and rebooting all the time.
After updating my system, I get a blank screen when I start the X. 

Normally (before the update, and in my current state), I see the first
few lines of output of startx, the screen turning on and off (because of
modesetting), and then my .xinitrc getting executed.

However, with the latest Xorg and nVidia versions, I see the first few
lines, and then X appears to freeze. I can switch to another tty and
check that it executed my .xinitrc and my WM is running, but if I switch
back, I just see a frozen image of whatever I was looking at before
switching to the terminal running the X. In fact, if when it starts I do
<Meta-Shift-Enter>touch x-works<Ctrl-D><Meta-Shift-Q> it does create a
file called x-works and exit normally. A log of this is available as
Xorg.18.log (attached).

I'm not very knowledgeable about the X, but it seems to me it is related
to this part of the log:
[  5167.048] (II) modeset(1): using drv /dev/dri/card0
[  5167.048] (EE) Screen 1 deleted because of no matching config section.
[  5167.048] (II) UnloadModule: "modesetting"
while in Xorg.17.log (attached), it does its job.

Here's the combinations of up/down-grading I tried after I got the blank
screen. The versions I had before the update were 355 and 17 and
graphical acceleration did work, but trying now, it doesn't (tried with
glxgears). Also, to downgrade xorg-server I also needed to downgrade
xf86-input-evdev and xf86-video-intel. I always remembered to recompile
the nvidia module with DKMS.

                  Xorg versions
                  1.17        1.18
    nVidia  355   No accel    nVidia complaint about X version, crash
   versions 358   OK          Blank screen

 $ lspci |grep 3D
04:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 840M] (rev a2)

I have also mangled with nvidia-xconfig, but it only made things that
were working not work, or had no visible effect. My xorg.conf is also

I'm curious as to why the 358-1.17 combo works, and latest doesn't, and
why the 355-1.17 combo used to work, and now works but glxgears doesn't
work with it. Thank you in advance for any suggestion,

Sorry that the attachments are in a tgz, but the original was rejected
(over 40K).

João Miguel
-------------- next part --------------
A non-text attachment was scrubbed...
Name: logs.tar.gz
Type: application/octet-stream
Size: 8600 bytes
Desc: not available
URL: <https://lists.archlinux.org/pipermail/arch-general/attachments/20151126/4ff76244/attachment.obj>

More information about the arch-general mailing list