[arch-general] Alsa Softvol and MOC

Storm Dragon stormdragon2976 at gmail.com
Sat Sep 26 14:29:27 UTC 2015

thanks for the suggestion. I installed it, but still get the same error and the volume controls still do not work.
On Sat, Sep 26, 2015 at 09:04:09AM -0500, AIS Information wrote:
>On 09/26/2015 07:00 AM, arch-general-request at archlinux.org wrote:
>> Send arch-general mailing list submissions to
>> 	arch-general at archlinux.org
>> To subscribe or unsubscribe via the World Wide Web, visit
>> 	https://lists.archlinux.org/listinfo/arch-general
>> or, via email, send a message with subject or body 'help' to
>> 	arch-general-request at archlinux.org
>> You can reach the person managing the list at
>> 	arch-general-owner at archlinux.org
>> When replying, please edit your Subject line so it is more specific
>> than "Re: Contents of arch-general digest..."
>> Today's Topics:
>>    1. Alsa Softvol and MOC (Storm Dragon)
>>    2. OVMF fails to build (mytbk920423 at gmail.com)
>> ----------------------------------------------------------------------
>> Message: 1
>> Date: Fri, 25 Sep 2015 15:06:27 -0400
>> From: Storm Dragon <stormdragon2976 at gmail.com>
>> To: Arch Linux General <arch-general at archlinux.org>
>> Subject: [arch-general] Alsa Softvol and MOC
>> Message-ID: <20150925190627.GA807 at frankendell>
>> Content-Type: text/plain; charset="us-ascii"; Format="flowed"
>> Howdy,
>> I have installed extra/moc 1:2.5.0-3. Reading through the docs, and things on the net, I found a way to set up a softvol control for it in alsa, so when I adjust its volume, it only changes the volume for moc. Everything went well, except, I can't adjust the volume from within the moc app, which should be possible because you can set the alsa device and mixer in the ~/.moc/config file.
>> It is using the right device, and amixer sset Mocmaster 50% sets the volume. It's just the in program controls that fail. When moc starts, it gives this error:
>> ALSA lib dlmisc.c:254:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_softvol.so
>> This makes me think that either a plugin is missing from alsa-plugins, or maybe moc is using an outdated way to change its volume. However, if the alsa controls are set to their defaults, the volume works fine, but it lowers the volume on the whole system.
>> I did a pacman search for alsa softvol but it didn't return anything. Is there anything I can install to fix this?
>> Thanks for any help
>> Storm
>my only guess would be to install this:
>as i see moc uses speex. just a guess though.

Powered by Arch Linux! I am registered Linux user number 508465: https://linuxcounter.net/user/508465.html
My blog, Thoughts of a Dragon: http://www.stormdragon.tk/
get my public PGP key: gpg --keyserver wwwkeys.pgp.net --recv-key 43DDC193
Twitter and Facebook are so ... yesteryear. Get your 2MB Social account TODAY! http://2mb.social/main/register
The great thing about Object Oriented code is that it can make small, simple problems look like large, complex ones.
"One more time we stare into the blackened sky, for tonight, in our hearts now we feel. One last time see our destiny reveal."
DragonForce - The Last Journey Home
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <https://lists.archlinux.org/pipermail/arch-general/attachments/20150926/8ef6d981/attachment.asc>

More information about the arch-general mailing list