[arch-general] Chromium Favorites Bar Partially Inoperative

Dutch Ingraham stoa at gmx.us
Mon Feb 1 00:11:24 UTC 2016

On Sun, Jan 31, 2016 at 11:08:16PM +0100, Damjan Georgievski wrote:
> > I just installed Chromium, v. 48.0.2564.97, two days ago.  I imported
> > my bookmarks from Firefox and enabled the bookmarks bar.  I added a few
> > new bookmarks to the bar, but not in my existing folders.
> >
> > Today, I tried to drag-and-drop the bookmarks into the folders on my
> > bookmarks bar, but nothing happened - the bookmarks just remained on
> > the bar.  In addition, it seems impossible to move anything on the bar,
> > i.e., adjusting the order of folders or bookmarks.  Everything just stays
> > where it was originally placed.
> >
> > For those who don't use Chromium, this is not normal behavior - one should
> > be able to drag-and-drop into folders, subfolders, and slide things
> > around at will.
> >
> > In fact, even in the bookmark manager it is not possible to drag-and-drop;
> > the only way I've found to move a bookmark into a folder is to copy and
> > paste it there, then delete the original.
> >
> > I've tried disabling my two extensions without luck, and I see no
> > recent activity on the boards or on Chromium's bug tracker.
> >
> > Anyone else seeing this?  Any suggestions?
> huh.
> possibly unreleated but I just experienced that drag&drop from dolphin
> to a html5 drop-zone doesn't work either.
> it even doesn't work from a directory view in chromium itself to a
> html5 page in chromium.

Thanks Damjan, but unfortunately I don't think it is related.

Actually, this is getting interesting.

First, this is related to Chromium, as Firefox does not exhibit this

Second, I decided to test the issue with KDE, DWM, and Awesome (Awesome
is what I was using when I first noticed the issue.)  The problem does
not exist with KDE or DWM - only Awesome.

Third, and this is the really interesting part, the problem only exists
on my right monitor; if I open Chromium on my left monitor, the bookmarks
work as expected.  In fact, I can even drag a running instance of Chromium
from the right monitor, where the bookmarks are not working properly, to
the left monitor and they begin working!

I'm using the [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series] card and
the xf86-video-ati driver.

I've tried starting X with and without an xrandr script, but it makes no 
difference. I've also looked at the Arch ATI wiki and tried some tweaks
to my 20-radeon.conf, without success.

I think this is most likely a driver issue than an Awesome/Chromium issue;
they are likely just exposing some underlying driver quirk.

Does anyone have any diagnostic/other hints?

More information about the arch-general mailing list