[arch-general] Keyboard lag issue

Gaëtan Harter hartergaetan at gmail.com
Mon Jun 20 20:55:35 UTC 2016

On Mon, Jun 20, 2016 at 7:17 PM, Manuel Groß <mgr at nordkrater.de> wrote:

> Hello there,
> I currently experience a weird keyboard lag issue which I yet failed
> to resolve. I had some help looking into it a bit (and obviously
> searched the web), but we couldn't identify the speficic problem. I hope
> someone could provide me pointers or hints on what to test out.
> I have a Thinkpad x250 running Arch Linux with Openbox and X11 on it.
> I use systemd-logind to log in, so X is started with the 'exec
> openbox-session' from my xinitrc. Not from some fancy lightdm or so.
> I do not have a certain date since when the issue occurs, but it has
> probably been a little over a month. I didn't make any major changes to
> my system then, and I do update regularly. This didn't occur when I set
> up the system.
> The issue is, that on some, certain programs, the keyboard input
> 'arrives' too late, with delays up to 1-2s. In other programs, this
> never happens at all. And in rare occasions, it is even fine for
> programs, in which I experience the problem.
> I checked logs at obvious locations, but neither the systemd journal,
> dmesg or the Xorg log were screaming 'I have an issue here'.
> The trackpoint always works as excpected and the touchpad is disabled.
> Programs where the delay occurs:
>  * sakura
>  * sublime
>  * wireshark (qt5 version)
> Programs which are fine:
>  * claws-mail
>  * geany
>  * xterm
>  * chromium
> The delay also never occurs in the system shell (Alt+F2) and xterm, so
> it's not the shell or oh-my-zsh.
> The program lists suggests, that it is not a problem due to a specific
> version of GTK or QT, since programs using either library (or none of
> them) are affected.
> I tried using 'libinput' instead of 'evdev' as a keyboard driver,
> but the change had no effect (I double checked the Xorg log which driver
> was actually used).
> In 'xev', all keystrokes arrive immediately.
> So seems not to be the kernel or the driver, nor a specific gtk or qt
> library.
> The next thing to test would probably be the xlib and the libxcb
> themselves. So I used 'downgrader' to downgrade each a few revisions
> (also their lib32-libraries) and checked for a change, without success.
> I don't know what to try next. Does anyone of you have an idea or
> already solved a similar issue? I'd appreciate any help on this.
> --
> Grüße/Regards
> Manuel Groß

Hi Manuel,

I have a Thinkpad T440p and I have the same issue with kernel 4.6, with
both 4.6.2-1 and 4.6.1-XX versions.
There is no issue with lts kernel 4.4.13-1.

>From what I experienced, gnome-terminal is impacted, and I think also

Gaëtan Harter

More information about the arch-general mailing list