[arch-general] Segmentation fault and (possibly) file system bug while removing gnome-extra

Robert W0ng leo_wsy at foxmail.com
Sun May 14 02:29:07 UTC 2017

Hello again, All.


I ran fsck in archiso this morning, and found sth interesting.

To sum up, fsck.f2fs exit with signal 11, arguing segmentation fault.
Just the same as the error I faced last night. (I wrote the previous
mail last night and sent it this morning.)

Now that I knew it's DEFINITELY a file system error. And I wonder if
there's any solution except formatting the whole partition.

Again, I shooted the error log and I'll post it here:

Lots of thx!!!


On Sun, 2017-05-14 at 07:19 +0800, Robert W0ng via arch-general wrote:
> Hi, All.
> For several reasons I decided to remove the group 'gnome-extra'
> from my system. During the uninstallation, something went wrong.
> For a 'funny' reason, which I may explain later, I wasn't able
> to post the error log in the form of text here, so I will upload
> a photo as an attachment[1] with this mail...
> So, I switched to a getty and started the uninstallation. No
> errors occourred until it reached the 15th package. The package
> name was 'telepathy-idle'. All of a sudden the system printed
> a large section of dmesg, saying something like it had run into
> a kernel bug(?). The pacman was then killed, leaving the zsh
> reporting a segmentation fault...
> I felt the possibility that I wasn't able to handle this problem
> on my own, so I took a photograph using my mobile without even
> thinking, which proved to be useful later. Then I ran 
> # dmesg >> /root/dmesg.output
> hoping to save the error log. I tried to restart the
> uninstallation, but the pacman freezed. Even pressing CTRL-C
> didn't work. I switched to another getty attemptting to terminal
> in, but after I entered 'root' and pressed ENTER, no any output.
> The course was just left there, blinking. Having no choice, I
> reboot the system using the magic sysrq keys...
> Rebooted, I checked the package changes. Confusingly, no packages
> was removed, even the previous should-be-removed 15 ones! Bad
> feeling about this, I checked the /root directory, and here came
> the most confusing part: The dmesg.output file was GONE! It
> seemed that all the data that should have been written to the
> disk were discarded...
> (And that's the reason why I have to post the error log in the
>  form of shooted image... Somehow, I found myself a potential
>  prophet... :P JUST KID...)
> Judged by this, together with the previous error log, I would
> say it's a file system bug... But, confused, how can an
> uninstallation of packages end up like this way? :(
> I would appreciate any help from you guys. Truly would. Thank
> you in advance! :)
> PS: I'm not going to post my pacman.conf here because all
>     modification I had ever done to this file was to enable the
>     color output. I suppose it can be excluded from the possible
>     causes... And if necessary, I would recur the
>     uninstallation with '--debug' flag enabled and report
>     it to the upstream developer...
> [1] Upadte: Unable to upload the image file because it's too
>             big to be attached in this mailing list... So I
>             uploaded it to a local website and I will post the
>             image address here.
> Image Address: http://imgsrc.baidu.com/forum/pic/item/7bf9f2c4b74543a
> 9b
> 9da16cf14178a82bb0114d4.jpg
> RW

More information about the arch-general mailing list