[arch-general] Broke Arch trying to change graphics driver

Junayeed Ahnaf nirjhor at outlook.com
Sat May 5 05:01:19 UTC 2018

I did a rollback too , seems like there's no easy way to go back from nonfree to free drivers.

On May 5 2018, at 12:00 am, Eric Blau <eblau at eblau.com> wrote:

On Fri, May 4, 2018 at 1:34 PM Junayeed Ahnaf via arch-general <
arch-general at archlinux.org> wrote:

So here's what happened, I was facing issue with proprietary nVidia driver
(screen tearing) so I thought I want to switch to the free one, so I
uninstalled nvidia with "pacman -Rs nvidia" , then I thought might as well
try a different kernel and installed zen. Now when I boot into either
kernel I am seeing "Starting display manager" then a black screen. I can
login to tty2 , but no display comes up.

I want to switch back to free driver, with preferably zen kernel. What
should I do? Thanks in advance.

I just hit a similar issue when trying to switch from nvidia to nouveau. I
was trying to switch from i3/Xorg to sway/Wayland. The proprietary nvidia
driver is unsupported with sway. I uninstalled the nvidia modules like you
did, disabled the lightdm display manager, and booted into nouveau. It
worked but was much too slow to be usable with my 4K display. I was getting
major lag. It was like getting 1 HZ refresh rate moving my mouse pointer

I switched back to i3/Xorg with the nvidia modules but when rebooting to
test, it failed with a black screen like you got. When I tried "sudo
modprobe nvidia" I got an "exec format error" message and the nvidia
module refused to load.

The nvidia module installed to the extramodules directory so I expected it
to work with the 4.16.4 kernel I'm running even though it was built on
4.16.1, but apparently that is not the case. Uninstalling and reinstalling
nvidia and nvidia-utils did not fix things.

Eventually I gave up and did a "zfs rollback" to restore the previous
system state and everything was fine after that. Sorry I don't have good
solution for you, but I wanted to chime in that I also encountered the same
problem and it was related to the nvidia modules not being loadable.


More information about the arch-general mailing list