[arch-general] [OT] Problems with uwsgi/Python and httpd

Peter Nabbefeld peter.nabbefeld at gmx.de
Thu Jan 24 08:19:25 UTC 2019

Currently, I keep getting the following strange message:
[Thu Jan 24 09:10:44.116126 2019] [proxy:error] [pid 4791:tid 
140494184179456] (111)Connection refused: AH00957: uwsgi: attempt to 
connect to (*) failed

I've already tried to remove the "Location" wrapper, replacing it by 
"ProxyPass /bud/ uwsgi://", but that doesn't work, either.

netstat shows me, uwsgi is running:
tcp        0      0* LISTEN      

emperor.uwsgi.service started, status seems okay (it even shows me 
entries for my app config).

It seems, sth. has to be changed in the ProxyPass directive, probably it 
has to be defined differently (i.e. documentation might be outdated or 

Kind regards


Am 23.01.19 um 23:35 schrieb Peter Nabbefeld:
> Hello,
> I've tried to get Python working with Apache httpd and 
> mod_proxy_uwsgi, but access to it results in an Error 503.
> In httpd.conf I activated the module. In vhosts configuration, I made 
> the following related entries:
>     DocumentRoot "/srv/http/my.host.name/"
>     <Directory "/srv/http/">
>         Options -Indexes
>     </Directory>
>     <Location "/bud/">
>         ProxyPass uwsgi://
>     </Location>
> In location /srv/http/my.host.name/bud/ there's a script named buddy.py:
> def application(env, start_response):
>     start_response('200 OK', [('Content-Type','text/html')])
>     return [b"Hello World"]
> The URL I'm using is: http://my.host.name/bud/buddy
> In /etc/uwsgi/vassals there's a configuration "example.ini":
> [uwsgi]
> chdir = /srv/http/my.host.name/bud
> module = buddy
> plugins = python
> I've started uwsgi in emperor mode, starting "emperor.uwsgi.service".||
> What am I doing wrong?
> Kind regards
> Peter
> PS: I've tried to find the necessary information in Arch Wiki or in 
> the uwsgi docs (e,.g. copied the Python example there ;-) ), but it 
> seems I'm missing some "glue" ....

More information about the arch-general mailing list