[arch-general] Issue with 'eject -T'

Ralf Mardorf silver.bullet at zoho.com
Sat Oct 19 09:30:10 UTC 2019


'eject -T' doesn't work anymore on my machine, resp. opening the DVD
drive doesn't work anymore, when using the traytoggle option. Opening
still works without an option and closing with the traytoggle option
also still works.

$ eject -V
eject from util-linux 2.34
$ eject -T
eject: CD-ROM eject command failed: Device or resource busy
$ grep util-linux /var/log/pacman.log | tail -6
[2019-06-21 08:19] [ALPM] upgraded libutil-linux (2.33.2-1 -> 2.34-2)
[2019-06-21 08:19] [ALPM] upgraded util-linux (2.33.2-1 -> 2.34-2)
[2019-06-21 08:19] [ALPM] upgraded lib32-util-linux (2.33.2-1 -> 2.34-1)
[2019-06-29 11:40] [ALPM] upgraded libutil-linux (2.34-2 -> 2.34-3)
[2019-06-29 11:40] [ALPM] upgraded util-linux (2.34-2 -> 2.34-3)
[2019-10-06 12:37] [ALPM] reinstalled util-linux (2.34-3)

I don't know when the issue started, but I'm quite sure it still worked
last month. I'm usually using 'eject -T' to open or close the DVD drive
by a keyboard shortcut.

I accidentally reinstalled util-linux a few days back, IOW that it was
reinstalled is meaningless, it might be that it even still worked this

Could somebody with an up to date Arch Linux install please run
'eject -T' from command line? I want to know if it's an issue on my side
or if it's a regression of a dependency or something else unrelated to
my machine.


$ uname -r

More information about the arch-general mailing list